z/OS Agent unable to start and terminates with RC16 if trace is not active

Document ID : KB000087465
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
COND CODE 0016 - Job Output

Version 12.0.0 of the z/OS Agent abends with an RC 16 immediately after startup if trace is not active.  

Investigation

The U02005078 is the last regular startup messages that is logged.  The last line in the log contains the timestamp only 
(next message should be U02000134): 
 
20161020/113857.853 - -------------------------------------------------------------------------------- 
20161020/113857.870 - Agent processID '67176178'. 
descarray is at 1218e020, size is 8 bytes 
descarray has 2048 entries, entry size is 788 
20161020/113859.620 - U02000045 Maximum number of open file descriptors a process may have: '65535,socket=2048' 
20161020/113859.635 - U02000066 Host information: Host name='S901', IP address='192.168.40.232' 
20161020/113859.638 - U02005051 Job information: Job name='SCJEX12', Job ID='S0031765', User ID='UC4SCJ' 
20161020/113901.278 - U02005078 WLM systems: 'S901 S902' 
20161020/113903.146 - 
 
When the Agent is started with a trace set via the ini file it starts up correctly: 
 
20161020/113946.908 - -------------------------------------------------------------------------------- 
descarray is at 1218e020, size is 8 bytes 
descarray has 2048 entries, entry size is 788 
20161020/113947.458 - U02000045 Maximum number of open file descriptors a process may have: '65535,socket=2048' 
020161020/113947.475 - U02000066 Host information: Host name='S901', IP address='192.168.40.232' 
20161020/113947.481 - U02005051 Job information: Job name='SCJEX12', Job ID='S0031766', User ID='UC4SCJ' 
20161020/113947.899 - U02005078 WLM systems: 'S901 S902' 
20161020/113954.925 - U02000134 Thread 'MAIN-THREAD' started. 
 
Environment:
OS: Z/OS
OS Version: N/A
Cause:
Cause type:
Defect
Root Cause: z/OS agent stops with completion code 16 after startup if trace ( or memory trace) is not active.
Resolution:
Update to a fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Automation Engine 12.1.0. - Available
Automation Engine 12.0.1. - Available
Additional Information:
Workaround :
When the Agent is started with a trace set via the ini file it starts up correctly:
TCP/IP=1

When the Agent is connected to the Automation Engine, disable the trace option in System Overview > Agents > Agent Properities