Xtraction - "An error occurred during the processing" - happened while running Dashboard

Document ID : KB000112750
Last Modified Date : 03/09/2018
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Issue:
The following error message appears when the Dashboard is running:

"An error occurred during the processing. Try again. If this continues to occur, contact the application administrator."

This error could happen after sometime the dashboards are running and being refreshed. At log files, it is possible you find error messages as below:

ERROR Xtraction.Service.SessionService - Error System.Data.SqlClient.SqlException (0x80131904): Execution Timeout Expired. The timeout period elapsed prior to completion of the operation or the server is not responding. ---> System.ComponentModel.Win32Exception (0x80004005): The wait operation timed out 

Xtraction.Service.SessionService - Error System.ApplicationException: Exception occurred updating user session 

ERROR Xtraction.AlertService.Threading.AlertHostThreaded - Error: 0 
System.Data.SqlClient.SqlException (0x80131904): Execution Timeout Expired. The timeout period elapsed prior to completion of the operation or the server is not responding. ---> System.ComponentModel.Win32Exception (0x80004005): The wait operation timed out 
 
Environment:
CA Service Desk Manager - any release
Xtraction 2018.2
Cause:
If Xtraction cannot talk to the SQL database, a generic error will be displayed in the User Interface (UI), and a more detailed error will be written to the log file. If there is a lengthy network error between the Xtraction server and the end user will see a "logout" as well.

In summary, the problem seems to be related to the connection to the LANDESK Service Desk database set up in the data model file. Either the connection details were entered/saved, or the details were incorrect, or the details were correct but not configured correctly on the database, etc. The specific error message that debug mode reveals would then further narrow down which of possible issues it might actually be.

Details on how to set debug mode in Xtraction can be found at below link:

How to Enable Verbose Logging for Xtraction
Resolution:
Please, try increasing the time out and potentially allow SQL traffic on the firewall to flow freely. You can configure the time out period that Xtraction waits before timing out by adding the following entry to the web.config file in the Xtraction\Web\Server folder.

<httpRuntime executionTimeout="300" />

This needs to go somewhere inside the first <system.web> block. Usually it is best to add it straight after the first <system.web> tag, you just need to make sure it is not already there somewhere else. Note that 300 means 300 seconds. Then recycled IIS.

Also open ports TCP 1433 and UDP 1434 for SQL and possibly enable named pipes in SQL Configuration Manager. You can enable it under default MSSQLSERVER instance, located at "SQL Server Configuration Manager (Local) >> SQL Server Network Configuration >> Protocols for MSSQLSERVER", by changing its status from "Disabled" to "Enabled".

Other actions that could be done:

Check if there is any issue with network team as well;
Check if there is any firewall between the SQL server hosting the Xtraction and CA SDM (MDB) databases and the Xtraction application server;
Check if there is any firewall enabled at the Windows Operating System.
Additional Information:
What is this Error and how to fix it?