XPS Transaction COMMIT has failed errors for AgentInstance in smps logs

Document ID : KB000046865
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue: 

We could see that below XPS Commit errors filling up frequently in smps logs for few agent instances.

[21487/-329315440][Tue Sep 20 2016 00:52:32][XPSIO.cpp:1594][CreateObject][ERROR][sm-xpsxps-00540] Previous error occurred on object "CA.SM::AgentInstance@PS-0000000000000000000000000a108980-pingfederateagent"

[21487/-329315440][Tue Sep 20 2016 00:52:32][XPSIO.cpp:1594][CreateObject][ERROR][sm-xpsxps-00540] Previous error occurred on object "CA.SM::AgentInstance@PS-0000000000000000000000000a108980-pingfederateagent"

[21487/-329315440][Tue Sep 20 2016 00:52:32][XPSPolicyData.cpp:1244][CommitOrTestRollback][ERROR][sm-xpsxps-00740] XPS Transaction COMMIT has failed.

[21487/-329315440][Tue Sep 20 2016 00:52:32][XPSPolicyData.cpp:409][CreateOrUpdateImpl][ERROR][CA-SM-Assert] Assert failed: Commit()

Environment:  

R12.52 SP1 CR04

Cause: 

This likely to be due to Agent Instance objects might have corrupted (missing of attributes) in Policy Store and throwing an error while updating.

Resolution:

Please try to delete the Agent Instance object (if not required) from Policy store and restart the Web-agent. This will create the new agent Instance in Policy store.

Kindly refer to "Policy Server Configuration Guide 12.52" "Agent Discovery Introduced" for more details.

https://support.ca.com/cadocs/0/CA%20SiteMinder%2012%2052-ENU/Bookshelf_Files/HTML/idocs/1766152.html

To delete the Agent Instance objects kindly go to:

Admin UI-->Infrastructure-->Agent-->Agent Instance, Select the unwanted/corrupted agent and delete it.

OR

use XPSExplorer option to delete it.

a) run XPSExplorer

xps1.JPG

b) select AgentInstance option (i.e 100)

xps2.JPG

c) search and delete the corrupted object which you want to delete.

Additional Information:

https://support.ca.com/cadocs/0/CA%20SiteMinder%2012%2052-ENU/Bookshelf_Files/HTML/idocs/1766152.html