XCOMN0602E unable to open queue data file with CA XCOM Data Transport for Windows

Document ID : KB000006013
Last Modified Date : 14/02/2018
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Issue:

Remote requests fail with the error message XCOMN0602E unable to open queue data file.

 

Cause:

This is normally a security issue. The userid used for the transfer request is missing permission to write to the files within the XCOM queue folder.

Resolution:
  • Write permission must be given to the folder where the queue data file is.  This is %XCOM_HOME%\Q by default.  It can be set to a different location using the QUEUE_PATH parameter in the xcom.glb file in the \config subdirectory.  Each and every XCOM transfer writes into that folder during processing.
  • Write permission must also be given to the folder where the xcom.log file is. This is %XCOM_HOME%\Q by default.  It can be set to a different location using the XLOGFILE parameter.
Additional Information:

The userid assigned to a remote transfer is determined by: 

  • Transfer parameters specified by the partner (USERID=, PASSWORD= and optionally DOMAIN=). If domain is specified, the userid needs to be defined in the domain. Otherwise it needs to be defined locally in the Windows box. 
  • If the incoming transfer does not specify user credentials, the default userid set by xcom.glb parameters XCOM_USERID= and XCOM_PASSWORD is used. 
  • If no default userid is set, the transfer runs under the security inherited from the xcomd service. 

If you need additional assistance, please contact CA Support.