X11 Setup GUI window has garbage characters

Document ID : KB000009221
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

I am installing Spectrum on RedHat Linux and getting an error during the .setuplin.exe part. The X11 Window drawn the setup GUI ok but when I select a component to install, whether Spectrum or SRAdmin, the next dialog will only show garbage characters and the text is unreadable. 

In Command Line while running the setup, there is an error: "Warning: Missing charsets in String to FontSet conversion"

 

Environment:
Linux RedhatCentOSSpectrum 9.4.x, 10.x and up
Cause:

This issue is likely caused by missing X11 fontsets for the OS. 

Resolution:

First thing you can try to to set the locale variables in case these are not set properly.

Run the following: 

export LC_ALL=C

or

export LC_ALL=en_US

You can verify by running

locale

 

Next is to verify X11 fonts are installed. You can see what fonts are installed with command fc-list

RedHat support mentions new Linux installations planning to use X Applications need to have font groups installed. See link below in "Additional Information" section. 

yum groupinstall fonts

A possible specific font which could be causing the issue may be xorg-x11-fonts-Type1.noarch

 

Last, if the above does not solve the issue, you may want to run debug during the install for a more verbose output for further clues: 

export LAX_DEBUG=true

then run the installer again and make note of any errors and research against the errors for possible solutions. 

Additional Information: