WV would not start. Reconnect attempt to EM repeats.

Document ID : KB000004354
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

 "WVCtrl.sh start" does not start and just repeats reconnect attempts as following:

 Using APMHOME: /introscope/Introscope10.3.0 

 Using JAVA_HOME: ../jre 

 Using EM Host: xxx.xxx.xxx.xxx 

 Using EM Port: zzzz 

 Reconnect attempt to EM: 1 

 Reconnect attempt to EM: 2 

 Reconnect attempt to EM: 3 

 :::::

Environment:
Linux or SunOS
Cause:

WVCtrl.sh is supposed to look for AND try BOTH nc and telnet on the OS. Currently, if both nc and telnet is installed and nc happens to fail to connect somehow, WV Start does not work. Script should then try telnet immediately if nc fails.  Instead it repeatedly attempts to reconnect using nc.

Resolution:

Script contains following, starting at line 238 (in 10.3):

Linux|SunOS)

if [ -e "${NETCAT}" ]; then

RESP=`${NETCAT}  ${NC_OPTS}  ${MOM_HOST} ${MOM_PORT} 2>/dev/null`

success=`echo $RESP | grep succeeded`

if [ -n "$success" ]; then

break

fi

elif [ -e "${TELNET}" ]; then

RESP=`${TELNET} ${MOM_HOST} ${MOM_PORT} 2>/dev/null`

success=`echo $RESP | grep Connected`

if [ -n "$success" ]; then

break

fi

else

echo "Cannot test for EM without telnet or netcat."

break

fi

;;

*)

 

* This should be changed to:

Linux|SunOS)

  if [ -e "${NETCAT}" ] || [ -e "${TELNET}" ]; then 

  if [ -e "${NETCAT}" ]; then

  RESP=`${NETCAT}  ${NC_OPTS}  ${MOM_HOST} ${MOM_PORT} 2>/dev/null`

 success=`echo $RESP | grep succeeded`

if [ -n "$success" ]; then

  break

fi

fi

if [ -e "${TELNET}" ]; then

 RESP=`${TELNET} ${MOM_HOST} ${MOM_PORT} 2>/dev/null`

 success=`echo $RESP | grep Connected`

 if [ -n "$success" ]; then

 break

 fi

fi

else

echo "Cannot test for EM without telnet or netcat."

break

fi

;;

*)

Additional Information: