WP ends immediately after starting: U00022022 Process 'UC4 WP1' ended, exit code='60'

Document ID : KB000084931
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
U00022022 Process 'UC4 WP1' ended, exit code='60'

When attempting to start the Automation Engine (AE) Work Processes (WPs), the WPs are started but immediately the processes end. When reviewing the log you will see the above error message.

Investigation
  • Check your permissions for the user starting the agent.
  • Ensure your firewall is configured correctly for the AE ports.
  • Ensure the "ucsrv.ini" file exists in the automation engine's bin directory

Solution
1) Check your permissions for the user starting the agent.

2) Ensure your firewall is configured correctly for the AE ports.
Make sure the ports assigned to each agent, the CPs and the WPs have been configured correctly on the firewall so communication between servers and agents is not being blocked.

3) Ensure the "ucsrv.ini" file exists in the automation engine's bin directory
The absence or accidental deletion of the ucsrv.ini file can produce this error. In this case you can download a new ucsrv.ini file, re-configure the settings and save.
Environment:
OS Version: N/A
Cause:
Cause type:
Configuration
Root Cause: Wrong environment configuration.
Resolution:
1) Check your permissions for the user starting the agent.
2) Ensure your firewall is configured correctly for the AE ports.
Make sure the ports assigned to each agent, the CPs and the WPs have been configured correctly on the firewall so communication between servers and agents is not being blocked.

3) Ensure the "ucsrv.ini" file exists in the automation engine's bin directory
The absence or accidental deletion of the ucsrv.ini file can produce this error. In this case you can download a new ucsrv.ini file, re-configure the settings and save.


Fix Status: No Fix

Fix Version(s):
N/A
Additional Information:
Workaround :
N/A