Workflow hangs in 'Waiting for user input' if default value of PromptSet element contains reference to EXEC VARA

Document ID : KB000084797
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
Access violation in module C:\AutomationEngine\bin\ZUSYNCHK.dll at 00007FFDBF47955C on read FFFFFFFFFFFFFFFF

When a task containing a PromptSet which uses a VARA.EXE as a data source is executed, the task remains in a 'Waiting for user input' status and the prompt set dialog box never appears.

Investigation

A task (job or workflow) has a PromptSet whose default values are specified at the workflow level.
The default values contain curly-brace-style VARA object references such as "{VARA,KEY, COLUMN}" that references a VARA.EXEC, which is a different VARA than the data source.
0EMb0000001UvVe.png

The referenced VARA.EXEC objects work fine on their own and clicking the 'Preview' button returns the expected results:
0EMb0000001UvVj.png

If the task is executed via the Java User Interface, it will hang completely and must be killed.
If it is executed in the AWI, the connection will be lost.
0EMb0000001UvWD.png

The PWP goes down and generates a dump file with an error message similar to this:
Access violation in module C:\UC4\WS112\AutomationEngine\bin\ZUSYNCHK.dll at 00007FFDBF47955C on read FFFFFFFFFFFFFFFF


 
Environment:
OS Version: N/A
Cause:
Cause type:
Defect
Root Cause: Workflow hangs in 'Waiting for user input' if the default value of a PromptSet element contains reference to EXEC VARA in versions 11.2.1 and 12.0.1.
Resolution:
Update to a fix version listed below or a newer version if available as this issue has only occurred in versions 11.2.1 and 12.0.1.
 

Fix Status: Released

Fix Version(s):
Component(s) : AE Server and Initialdata

Automation Engine 12.0.2 - Available
Automation Engine 11.2.1 HF1 - Available
Additional Information:
Workaround :
N/A