Work item is not send to default approver.

Document ID : KB000103071
Last Modified Date : 22/06/2018
Show Technical Document Details
Issue:
Context:
IM r14.1.0.

Description:
This is a policy based workflow for a modify user event.
The workflow process for the approval policy is the OOTB EscalationApproval.
The "Escalation Approver" section is set for a User ID.
The "Default Approver" section is set for a list of users belonging to an admin role.
The "Primary Approver" section is set with a custom participant resolver class which does not return users.
With this context the users in the "Default Approver" scope should receive the approval but they do not.
 
Environment:
The prerequisite to get this issue is a system/email definition as "Workflow Pending" type for "escalation approval" event and
the recipient must be workflow approvers. (with one static address then no issue).
 
Cause:
The root cause of this issue is a "Concurrency error";
e.g.:
ERROR [org.jboss.as.ejb3.invocation] (Worker_actionq#ActionQ1#WPDS_1) JBAS014134:
EJB Invocation failed on component WorkItemUpdatePvt_EJB for method public abstract com.workpoint.common.data.WorkItemQueryData
com.workpoint.server.pojo.WorkItemUpdatePvt.changeState(java.lang.String,java.lang.String,com.workpoint.common.data.WorkItemQueryData,short,int,int,java.lang.String,java.lang.String) throws com.workpoint.server.ejb.WorkPointEJBException:
com.workpoint.server.ejb.WorkPointEJBException: Concurrency error. Another user has updated this Job object since you selected it. Please re-select Job 51:WPDS and attempt this operation again.
 at com.workpoint.server.pojo.GenericServerBean.createException(Unknown Source) [iam_im_wpServer.jar:]
 at com.workpoint.server.pojo.GenericServerBean.createException(Unknown Source) [iam_im_wpServer.jar:]
 at com.workpoint.server.pojo.WorkItemUpdatePvtBean.changeState(Unknown Source) [iam_im_wpServer.jar:]
Resolution:
Hot Fix DE358742 verified on IM 14.1.0.CP3 and IM 14.1.0.CP4.
Delivered Files     ims.jar, imsapi6.jar, identitymanager.jar, user_console.jar, idmmanage.jar
 
Additional Information:
Please contact CA Support if this Hot Fix is not yet included into a cumulative patch and you need it.