Will .NET 10.2 agent pick up an app running in .NET 2.0 compatibility mode with .NET 4.5 or 4.6

Document ID : KB000094816
Last Modified Date : 04/05/2018
Show Technical Document Details
Question:
  We have an application that we're looking to monitor. It was built on .NET Framework 2.0. The servers have .NET Framework 4.5 or 4.6 installed. The application has been configured to leverage .NET 2.0 comparability mode of .NET Framework 4.5 / 4.6. Will the agents be able to pick up the application? 
Answer:
With the .NET framework version – we support versions 3.5 and above with 10.2. However, underlying .NET CLR version – APM supports all the underlying CLR versions that can be used with the supported frameworks. .NET framework 4.0/4.5 apps can run on 2.0 CLR and hence will be supported.

Just to be safe, you may want to review this doc by Microsoft for any backwards compatibility issues in .NET.

https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/version-compatibility