Will Java Active Responses work after upgrading from R12.52 release to R12.6 or R12.7?

Document ID : KB000015665
Last Modified Date : 14/02/2018
Show Technical Document Details
Question:

We currently use an Active Response on our R12 52 SP1 Policy Server. Our Active Response is based in a jar library compiled on the current Java version on the Policy Server (1.6.0 32-bit).

We are planning to upgrade to CA SSO 12.6 or 12.7, and we will like to know if the Active Response will continue to work if we upgrade, or if some actions would be necessary to make it work.

This active response will continue to work if we switch on CA SSO 12.6 or 12.7 or some actions will be necessary?

Environment:
Policy Server R12.52 SP1
Answer:

R12.6 and R12.7 Policy Server is 64-bit based, and minimum Java version supported is 1.8.0 64-bit. In order to the Active Expression to work after upgrading to R12.6 or R12.7, you need to recompile the jar library with a supported Java version for 64-bit.