Why is my Flow Statistics page not showing data?

Document ID : KB000032002
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem:

When navigating to the Flow Statistics page in NFA 9.3.2+ you may find that the page may load correctly but the graphs are blank and show "No Data Available" even though there is data currently processing and able to be viewed.  

The issue would look like this:

Capture.PNG

**Note** If it looks like the the page is not loading correctly at all please see: Flow Statistics page fails to populate graphs

 

Another symptom would be that the x:\CA\NFA\REPORTER\Logs\FlowStatsQueryThreadLog2015-xx-xx.log will show normal logging like, "Updating flow stats table" and "Finished updating flow stats table" however when you go to the reporter.flow_stats table it is completely blank or not updating with the latest entries. 

 

Environment:  

NFA 9.3.2 and newer 2-tier or 3-tier Distributed. 

 

Cause:

Port 8067 may be blocked in one direction between the Console to Harvester.

 

Resolution:

The Console on NFA 9.3.2 will communicate over TCP Port 8067 (which is a new port) bidirectionally with the Harvester.

This port should be open BOTH ways (inbound and outbound) on both the Console and Harvester as the Harvester will be making responses back. 

Once the Firewall or ACL rules are set in place the reporter.flow_stats page will start filling up with data.  

At that point the Flow Statistics page will be functioning properly. 

 

Additional Information:

Tech Tip: NFA 9.3.2 New Flow Statistics displays flow rates of all of your Harvesters (replaces NAST/NFAParser)

NFA 9.3.2 Release Notes

NFA 9.3.2 Flow Statistics Documentation

Flow Statistics page fails to populate graphs