Why is it required to download the JCE Unlimited Strength files for Spectrum?

Document ID : KB000057296
Last Modified Date : 14/02/2018
Show Technical Document Details

QUESTION: Why is it required to download the JCE Unlimited Strength files for Spectrum?

Our customer is requesting info about the local_policy.jar file, based in the installation documentation of Oneclick for Spectrum 10.0. "https://docops.ca.com/display/CASP10/Install+JRE+and+JCEUnlimited+Strength+Files" in next step is required to substitute the local_policy.jar: 

"Rename the existing "local_policy.jar" as "local_policy.jar.backup". In case the file is in use, stop the applications using it before proceeding." 

The customer wants to know why is required to download it and what security policies introduce this file. 

Could you help me with this? 

 

ANSWER: The JCE Unlimited Strength files have been a OneClick client requirement since the release of Spectrum 09.04.00.00. The following is from the Spectrum 09.04.00.00 release notes: 

 

"Install JRE and JCEUnlimited Strength Files on OneClick Client 

This release of CA Spectrum includes JRE 1.7.0_60 and JCEUnlimited Strength Files. The JCEUnlimited Strength Files are required for OneClick cryptography requirements. To install these two components on OneClick client, click the Install JRE and JCEUnlimited Strength Files option on OneClick home page and follow the steps thereafter. 

 

After you install the JRE and JCEUnlimited Strength Files, you can start OneClick. When you launch the OneClick console, you may get a security warning message. Ignore the warning and continue. For more information about the warning, see Java Security Warning (see page 15). 

 

JCEUnlimited Strength Files available with CA Spectrum 9.4 are compatible with JRE 7 only. If you are already on JRE 7, place the JCEUnlimited Strength Files in JRE 7. If you are not on JRE 7, install JRE 7 first and then place JCEUnlimited Strength Files in JRE 7. 

 

Note: If you try to launch OneClick without placing the JCEUnlimited Strength Files in JRE7, a pop-up message appears reminding you to do so. Click OK, and do the needful." 

 

ADDITIONAL INFORMATION: After the release of Spectrum 09.04.00.00, some customers did have issues with clients being able to install the JCE Unlimited Strength files on their local systems. The CA Spectrum Sustaining Engineering team developed PTF patches for Spectrum 9.4 and 10.0 that removed the requirement for clients to install the JCE Unlimited Strength files. Please reference knowledge document TEC1961228 for more information.