Why does my CABI 6.3 for Linux install fail through the GUI with error "Error while configuring postgreSQL database"?

Document ID : KB000071656
Last Modified Date : 22/02/2018
Show Technical Document Details
Question:
When installing Jaspersoft 6.3 (CABI 6.3) on a Linux server that meets the requirements for a GUI install, why does the installation always fail with “Error code 19031 and error message is "Error while configuring postgreSQL database"?
 
Environment:
Cabi 6.3
RHL versions supported by the GUI install:
RHEL 6.4
RHEL 6.6
RHEL 6.7
RHEL 7.1
RHEL 7.2
Answer:
It is a requirement to have the locale set to en_US.UTF8, otherwise the install will fail with the above error.
Linux command to run:
LANG= en_US.UTF8 ; export LANG

Then rerun the setup and it should now be successful.