Why does Introscope search return different results for live and historical metrics?

Document ID : KB000009136
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Why does Introscope search return different results for live and historical metrics?

 While running Introscope search live for a particular metric, the correct number of agents are returned. But looking at yesterday or some past range, then many agents are not being displayed. Looking at individual agents during yesterday or some past range shows metric data.

Environment:
All supported APM releases
Cause:

Live versus historical data may not always be the same. There are some reasons for this:

1. They may not match due to differences in query time periods. (e.g. Different resolutions or starting and ending times)

2. Live metrics consider random metrics out of the results to show the filtered 100 while historical metrics always consider metrics with data points.

3. Top N in live mode considers the latest 15 second data to show the Top N metrics on the graph. In contrast for historical mode, the entire eight minutes or custom time zone is aggregated to show Top N metrics.

4. Cluster performance issues such as a slow or non-responsive collector. If the collector does not respond within the time limit, then the MOM proceeds with the exiting data.

Resolution:

Later releases have made some improvements in this area. If the issue is not addressed by the above causes, please open a case.