Why does a new 3.2 PAM client ask for an update when connecting to a new PAM 3.2 instance?

Document ID : KB000109946
Last Modified Date : 07/08/2018
Show Technical Document Details
Introduction:
We downloaded and installed the PAM 3.2 client in a Citrix Desktop. After starting it up and connecting it to a new PAM 3.2 instance with no patches applied, the screen says "Update is required", and "New version 3.2.0.331". We would have expected the versions to match given that both client and PAM server are at 3.2 GA level. A Citrix desktop is provisioned for users when needed and always starts out with a new PAM client installation. It can be confusing to users to be asked to update the client every time they start a new desktop session.
Question:
Is there a PAM client version available for download that matches the PAM 3.2 GA version exactly?
Environment:
PAM 3.2, but this applies to all supported PAM releases as of August 2018.
Answer:
There is no exact version match between PAM clients available for download from the cloud and PAM server releases. The client typically is uploaded prior to a new release to make sure it is available on the GA date. Even if we started out with an exact version match, it would be of very limited value:
- Any PAM patch may update one or more client jar files on the PAM server causing a mismatch.
- Resigning jar files with a custom signing certificate will create new versions and require an update.
- The PAM client installer may get updated with a fix that will change its version.

PAM users will have to be informed that the need for an update on first launch is expected and not a problem.