Why can't my OPS/MVS MSF link connect to AP?

Document ID : KB000031355
Last Modified Date : 14/02/2018
Show Technical Document Details

Symptom:

You have gone through the steps indicated in the AP and OPS/MVS manuals and TEC1441034 about setting up CCI and MSF on the mainframe and on the AP Server, you have verified that CCI connection is established from AP to the mainframe, and you have configured MSF links, but you have noticed that your OPS/MVS MSF link to the AP server is showing as INACTIVE. You also might notice that when you run the "rmtcntrl status" command at the Windows Server command prompt, that the MSF link for your local AP Server is missing from the list. You also notice a message in the AP Log function window that indicates you do not have sufficient privileges to use the OPS interface.

 

Root Cause:

As indicated in the AP Log message, you do not have sufficient privilege to use the OPS/MVS interface. The user account which you are running Automation Point with does not have the create global objects privilege, specifically. This is documented in the Component Privileges section of the AP r11.5 wiki manual.

 

Solution:

You must grant the Windows user that you are running Automation Point with the 'Create Global Objects' Privilege, regardless of which Operating System you are using. Here is some documentation on this privilege: Create Global Objects Right.

To add this right to a standard Windows User, follow this guide: Microsofot Tech Net User Rights Doc.