Why are emails not being sent from CA PAM?

Document ID : KB000006204
Last Modified Date : 17/04/2018
Show Technical Document Details
Issue:

PAM has been configured to send emails, but they are not being sent.

Cause:

The most common cause of emails not being sent is that they haven't been properly configured. In CA PAM there are 2 places where emails can be configured & each is responsible for certain types of emails.

On the Access side of CA PAM, "monitor" emails are responsible for emails like "user X has logged in".

This is configured under:
  • 2.X: Config > Monitor
  • 3.X: Configuration > Monitor

The Password Management side email settings are responsible for emails sent for password requests, approvals & view notifications.

This is configured under: 
  • 2.X: Policies > Manage Passwords > Settings > Email Settings
  • 3.X: Settings > Credential Manager > Email Settings
Resolution:

Ensure that the correct email service(s) have been configured and enabled.

Access side "monitor" email problems can be diagnosed by stopping and starting the service. If properly configured this should send and email from the 'Appliance From Address' to the 'Admin Email' saying: "This is a test from the Xsuite Monitor to make sure mail is working properly, and is also an indication that the Xsuite Monitor is attempting to be started"

Password Management email problems can be diagnosed by enabling "Enable SMTP Server Debug" in the email settings, reproducing the issue & then reviewing the Tomcat logs under Config > Diagnostic for related info & errors.

Additional Information: