Why am I getting a PSA0311 DATASTORE VALIDATION FAILED/VERSION INCOMPATABLE message?

Document ID : KB000050152
Last Modified Date : 14/02/2018
Show Technical Document Details

Introduction: 

This document explains what causes a PSA0311 DATASTORE VALIDATION FAILED/VERSION INCOMPATABLE message.

Question: 

Why am I getting a PSA0311 DATASTORE VALIDATION FAILED/VERSION INCOMPATABLE message?

Environment:  

z/OS 1.11 and above.

Answer: 

The PSA0311 message occurs when a Datastore from a previous release (e.g. r14) is used to collect data in a newer release (e.g. r17). A new Datastore must be created for the new release. Afterwards, you can run the PSADSCPY member in your High.Level.CDBASRC library to copy the data from your Old Datastore into your new one.

Additional Information:

Starting with release 16, datastores created by release 15 & above can be used without having to run the PSADSCPY conversion job. However, once the datastore is viewed using the higher release, it can no longer be viewed by the older release unless it's appropriate Datastore Compatibility PTF is applied.