Which Datadictionary Service Facility (DSF) modules must be used with CICS/TS 4.1 and above?

Document ID : KB000017681
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

The CA Datacom load library CABDLOAD contains several versions of some DSF modules. For example, there are three different versions of the DDCICSnn module, depending on the CICS/TS release:

DDCICS22
DDCICS31
DDCICS32

If running any CTS release above 3.2, is a new set of modules required?

Solution:

DSF Programming Guide manual contains a compatibility matrix for DDBSCnn module:

___________________________________________________________
For CICS Transaction     Running Under     Use
Server
___________________________________________________________
1.1                       z/VSE             11
___________________________________________________________
3.1 	                  z/OS              31
___________________________________________________________
3.2                       z/OS              32
___________________________________________________________
4.1 or higher             z/OS              32
___________________________________________________________

This is also valid for all the other DSF modules (DDPCADnn, DDCICSnn, DDCADnn): for CICS/TS 4.1 and above the modules suffixed with 32 must be used, so no need for a new set.