When you get error messages when installing or upgrading CA Harvest SCM on Windows

Document ID : KB000045643
Last Modified Date : 14/02/2018
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Problem:

While installing or upgrading CA Harvest SCM on a Windows platform you may see an error message like this:

SCM Workbench was unable to load a component driver (HarvestProject.Project.1) vital to the operation of this project.  Setup for this product has not been completed or this product's configuration has become corrupt.

Please contact administrator or Customer Support

error code=0x00005210

Environment: 

CA Harvest SCM all versions on the Windows platform

Cause:

This can happen for a variety of reasons such as

  • Incomplete uninstallation of a previous version of Harvest
  •  Insufficient operating system privileges of the user performing the installation

Workaround:

To complete the installation, you should first check to be sure your userid is a member of the “Local Administrator” group on the Windows computer, and that you have privileges to update the Windows registry, and to create folders and write files to the following folders:

  • C:\Program Files
  • C:\Program Files (x86)  … (if this is a 64-bit computer)
  • C:\Windows\System32
  • C:\Windows\SysWOW64 … (if this is a 64-bit computer)

If you are installing from an installation package prepared by your system administrator, you may want to obtain a copy of the installation folder for the component you want to install from the CA Harvest SCM Installation DVD image

If your installation folder has both a file with a “msi” extension and a “setup.exe” file, be sure to always use the “setup.exe” file for your installation.

To do a thorough uninstall and fresh installation of the CA Harvest SCM software (after first shutting down any broker, hserver, rtserver or agent processes running), please follow these steps:

1.    Go to your Control Panel -> Programs window and uninstall Enterprise Communicator

2.    While still in your Control Panel -> Programs window, uninstall all CA Harvest SCM components.

3.    Check your Windows system environment variables. 

a.    Check your system PATH variable to be sure all references to the SCM folder (C:\Program Files\CA\SCM) or the pec folder (C:\Program Files (x86)\CA\SharedComponents\pec) have been removed from the PATH environment variable

b.    Delete any other SCM-specific environment variables, like CA_SCM_HOME, CA_SCM_LOCALHOME, HARVESTHOME, LOCALHARVESTHOME, etc.

4.    Backup any scripts or arg files you need to keep, then delete or rename any of the following folders that you find on your system:

  • C:\Program Files\CA\SCM folder
  • C:\Program Files (x86)\CA\SCM folder (if this is a 64-bit computer)
  • C:\Program Files\CA\SharedComponents\pec (if this is a 32-bit computer)
  • C:\Program Files (x86)\CA\SharedComponents\pec (if this is a 64-bit computer)

5.    Reboot the computer

6.    Install your CA Harvest SCM components (server, client, agent) again.  (no need to reboot between each component installation)

7.    Reboot one more time.

Additional Information:

Before performing any installation or upgrade of the CA Harvest SCM Software, you should always read the Release Notes and the Implementation Guide for your version of CA Harvest SCM.  Detailed information on how to prepare your computer for installation and how to complete the installation can be found there.

As always, please contact CA Technologies support for CA Harvest Software Change Manager if you have further questions.