When uploading attachments in Service Desk larger than 1Mb fail to be uploaded

Document ID : KB000109067
Last Modified Date : 01/08/2018
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Issue:
When attempting to load attachments larger than 1Mb fail to be uploaded, no error messages are captured in the log files. Fiddler will show an error similar to:

HTTP/1.1 413 Request Entity Too Large
Server: nginx/1.14.0
Date: Tue, 31 Jul 2018 13:52:33 GMT
Content-Type: text/html
Content-Length: 199
Connection: close
Environment:
Service Desk 14.1 or higher
Internet Information Services
LoadBalancers (nginx or others)
Cause:
The load balancer that is referenced in the Fiddler trace "Server: nginx/1.14.0"  had configured the client_max_body_size to 1Mb causing that higher values wont be able to pass through it.
The error "HTTP/1.1 413 Request Entity Too Large" is a generic error and it wont specify which server caused the error using Fiddler or other proxy tools can help to find out the root cause.
Resolution:
In the load balancer update the value for the setting client_max_body_size which by default is set to 1Mb and set it to the necessary size.
Additional Information:
Nginx documentation
Setting the maximum file size of Attachments in Service Desk/CMDB
Large file upload failure for Web application calling WCF service – 413 Request entity too large