When upgrading the MSP Interface, receive an error message that the CAClarityAddin is already installed

Document ID : KB000046121
Last Modified Date : 14/02/2018
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Issue:

When upgrading the MSP Interface, receive an error message that the CAClarityAddin is already installed. Once excerpt of the error that may be generated during the install is: There was an error during installation: The customization cannot be installed because another version is currently installed and cannot be upgraded from this location. To install this version of the customization, first use Add or Remove Programs to uninstall this program: CAClarityAddIn. Then install the new customization from the following location: file///C:/CA Clarity PPM MSPInterface/addIn/CAClarityAddIn.vsto

addinerror.JPG

Environment:

Applies to all supported PAS environments for specified releases.
 
Cause: 
 
This can be caused by a few issues, the most common being that parts of the Addin (Including Registry Keys or files in the Users folder on the machine) were not properly removed during the uninstall (due to access restrictions or other issues on the workstation). 
 

Resolution: 

Solution 1: Delete the below 2.0 folder after creating a backup of the folder. If that doesn't help, then proceed to solution 2 below and delete the extra registry keys as well (if they exist). 

  1.  Open C:\Users\%USERNAME%\AppData\Local\Apps
  • (May need to go into Organize->Folder and Search Options->View->Select radio button 'Show hidden folders, files and drives' and click OK to see the AppData folder). 

      2.  Delete the 2.0 folder after creating a backup.

      3.   Install the CAClarityAddin: 

  •  Navigate to the following folder directory: CA\Clarity\CA Clarity PPM MSPInterface\addin and double click setup.exe to run through the install process for the Addin.

Solution 2: 

  1. Delete the following keys/files (if found) referencing the CA Clarity Addin after taking a backup of the registry
  • HKEY_CURRENT_USER\Software\Microsoft\VSTA\Solutions\{GUID}Check to ensure that you're deleting the right key (should reference CAClarityAddin). 
  • HKEY_CURRENT_USER\Software\Microsoft\Office\MS Project\Addins\CAClarityAddIn (Delete entire folder) 
  • HKEY_CURRENT_USERS\Software\Microsoft\Windows\CurrentVersion\Uninstall (Delete any CAClarityAddin references) 
  • HKEY_USERS\5-1-5-21-(a long string of numbers that vary by machine)\Software\Microsoft\Office\14.0\Common\CustomUIValidationCache (Just need to delete the registry item in the directory that references the CAClarityAddIn)

    2. Delete the following folder on the machine after creating a backup. (This may need to be done a second time if the folder reappeared after attempting solution 1):

  •  Open C:\Users\%USERNAME%\AppData\Local\Apps
    • (May need to go into Organize->Folder and Search Options->View->Select radio button 'Show hidden folders, files and drives' and click OK to see the AppData folder). 
  •  Delete the 2.0 folder after creating a backup. 
  •  Install the CAClarityAddin: 
    • Navigate to the following folder directory: CA\Clarity\CA Clarity PPM MSPInterface\addin and double click setup.exe to run through the install process for the Addin.