When trying to install the Web agent plugin I am getting a usage error.

Document ID : KB000016023
Last Modified Date : 14/02/2018
Show Technical Document Details
Question:

We are attempting to install the Web Services plugin but are seeing this error:

usage: plugininstaller <packed file> <agent directory> [<stdin path> [<force override flag>]]

 

Environment:
Product: Workload Automation AE 11.xPlatform: WindowsDatabase: Oracle, Sybase, MS SQL
Answer:

A common cause for an issue like this is if the directory name(s) include spaces.   Solutions are use the 8dot3 naming convention for the directory names or copy the webservice.pak to the agent directory and run the install from there or include the options in double quotes.

Example 1:

PluginInstaller E:\CA_Workload_Automation_Agent_R11_3_4_for_Web_Services\CA_Workload_Automation_Agent_R11_3_4_for_Web_Services\webservice.pak D:\Progra~2\CA\Worklo~1\SystemAgent

Example 2:

copy E:\CA_Workload_Automation_Agent_R11_3_4_for_Web_Services\CA_Workload_Automation_Agent_R11_3_4_for_Web_Services\webservice.pak d:\Progra~2\CA\Worklo~1\SystemAgent

cd D:\Progra~2\CA\Worklo~1\SystemAgent

PluginInstaller webservice.pak . 

Please make sure to include the ending period as that is the destination directory for the plugin.

Example 3:

PluginInstaller E:\CA_Workload_Automation_Agent_R11_3_4_for_Web_Services\CA_Workload_Automation_Agent_R11_3_4_for_Web_Services\webservice.pak "D:\Program Files (x86)\CA\Workload Automation AE\SystemAgent"