When trying to install the ITCM Universe by using the "Install BIR" Wizard in CABI, the installer fails with exit code 10, and a popup error stating, "An internal error occurred. Please contact CA support."

Document ID : KB000022064
Last Modified Date : 14/02/2018
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Problem:

When trying to install the ITCM Universe by using the "Install BIR" Wizard in CABI, the installer fails with exit code 10 and a popup window stating:

"An internal error occurred. Please contact CA support."

See the screenshots below

Figure 1

Figure 2

 

Below is the full Error displayed in the output window of the installer.

   BOXI is installed at: C:\Program Files (x86)\CA\SC\CommonReporting3
   start BIConfig
   ==============
   CMD= BIConfig.bat -h DOMAIN1 -n 6400 -u walch21 -p <password is not logged> -s secLDAP -x "<?xml version=\"1.0\"?><biconfig version=\"1.0\">  <step priority=\"1\">    <add>
   <biar-file name=\"C:\Users\Administrator\Desktop\ITCM Install\SQL BIAR file\CA ITCM.biar\">   <networklayer>ODBC</networklayer>   <rdms>MS SQL Server 2008</rdms>
<username>ca_itrm</username> <password><password is not logged></password> <datasource>ca_itcm</datasource>
<server>DOMAIN1</server> </biar-file> </add> </step></biconfig>"
BIConfig exits with 0
start ReplicateReports ====================== CMD= ReplicateReports -boUser username -bopwd -f C:\Users\ADMINI~1\AppData\Local\Temp\2\rad8E1B9.tmp Unable to retrieve Source folder and its parent folder information java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 at java.util.ArrayList.RangeCheck(Unknown Source) at java.util.ArrayList.get(Unknown Source) at com.crystaldecisions.sdk.occa.infostore.internal.InfoObjects.get(InfoObjects.java:530) at com.ca.reports.replicate.ReplicateReports.retrieveSourceFolder(ReplicateReports.java:73) at com.ca.reports.replicate.ReplicateReports.main(ReplicateReports.java:312) ReplicateReports exits with 10

Environment:  

CA Client Automation R12-12.9

 

Cause: 

The username used for the CABI server, is not the CABI Enterprise Administrator account.

By Default this value is set to CABIUser, but should be changed to "Administrator". Also make sure the Authentication type selected is set to "Enterprise".

The Enterprise "Administrator" account has more privileges within CABI then users who are granted Administrator rights. When a user is granted Administrator rights in CABI, there are implicit hidden 'denies' added to their profile that prevent them from having the same privileges as the Enterprise account which is actually named "Administrator".

 

Workaround:

To correct the install problem, follow the steps below.

  1. Use the "Previous" button to go back through the installer, until you get to the "Enter the credentials for the CABI server" screen.

  2. Change the Username to "Administrator" and the Authentication type to "Enterprise"

    Figure 3

  3. Click next and proceed until you get to the final screen of the installer.

  4. Select "Deploy" again and wait for the ITCM Universe to be deployed.

    Figure 4

  5. If successful, you will not get any popup message and will see the last exit code as zero. (see below)

    You should not be able to run reports from the Central Management Console or Infoview.

    Figure 5

    For your reference, a complete successful output from the output window should look like below.
       BOXI is installed at: C:\Program Files (x86)\CA\SC\CommonReporting3
     
       start BIConfig
       ==============
       CMD= BIConfig.bat -h domain1 -n 6400 -u Administrator -p <password is not logged> -s secEnterprise -x "<?xml version=\"1.0\"?><biconfig version=\"1.0\">  <step priority=\"1\">
       <add>   <biar-file name=\"C:\Users\Administrator\Desktop\ITCM Install\SQL BIAR file\CA ITCM.biar\">   <networklayer>ODBC</networklayer>   <rdms>MS SQL Server 2008</rdms>   
       <username>ca_itrm</username>   <password><password is not logged></password>   <datasource>ca_itcm</datasource>   
       <server>DOMAIN1</server>   </biar-file> </add> </step></biconfig>"
       BIConfig exits with 0
     
       start ReplicateReports
       ======================
       CMD= ReplicateReports -boUser Administrator -bopwd  -f C:\Users\ADMINI~1\AppData\Local\Temp\2\rad35949.tmp
       Program Terminated Successfully. Return Code : 0
       ReplicateReports exits with 0
     
       start deploy custom inventory utility
       ======================
       CMD= "C:\Users\Administrator\Desktop\ITCM Install\ca-dsm-custom-inventory-utility.win32.exe" -s
       Deploy custom inventory utility exits with 0
     
       start ConfigureUniverse
       ======================
       CMD= ConfigureUniverse.exe -boUser Administrator -bopwd  -f C:\Users\ADMINI~1\AppData\Local\Temp\2\radE570C.tmp
       Successfully logged into the cms. The source universe is imported & opened...
       The derived tables are updated successfully.
       Universe Successfully Exported...
       --------------------------
       Program Terminated Successfully. Return code: 0
       --------------------------
     
       ConfigureUniverse exits with 0