When trying in provisioning manager to see the content of endpoints/properties managed by JCS following Error is shown - ETA_E_0019<RDI>, DYN Endpoint 'endpoint name' read failed: Unable to connect to Connector Server: ldaps://SERVER-FQDN:20411.

Document ID : KB000005266
Last Modified Date : 14/02/2018
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Issue:

This KD covers the scenario of which all managed endpoints by this JCS server cannot be connected to. Simple actions like viewing the endpoint properties from provisioning manager produce the error above. If your case scenario only involve one or more but not ALL endpoints, this solution is not for you. If this does suite your scenario read on.

 

Note: This problem was observed on server running out of disk space.

 

Check the following JCS logs for these messages to see that indeed the same problem is qualified

 

jcs_daily.log

ERROR  - Unable to create application context for [com.ca.jcs.provisioning.adapter], unsatisfied dependencies: Dependency on [Additional information about depencies may vary)

 

ERROR  - Application context refresh failed (OsgiBundleXmlApplicationContext(bundle=com.ca.jcs.provisioning.adapter, config=osgibundle:/META-INF/spring/*.xml))

 

 

 

servicemix.log

 

Unable to create application context for [com.ca.jcs.provisioning.adapter]….

 

 

 

jcs_service_stderr.log
Exception in thread "Thread-##" java.lang.RuntimeException: JCS@<server_name>: Failed to initialise the standalone server manager

 

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Caused by: javax.naming.NamingException: JCS@Iamappvprd1: Failed to create standalone configuration partition [Root exception is javax.naming.NamingException: JCS@<server_name>: Failed to create a JDBM partition: eTConfigContainerName=SA Configuration,dc=etasa [Root exception is javax.naming.NamingException [Root exception is java.io.StreamCorruptedException: invalid type code: 00]]]

 

Environment:
12.6.X envionments
Cause:

This problem was observed on server running out of disk space. Can occur due to a other disk problem.

 

Resolution:

 

Solution

1. Navigate to: %CA_HOME%\Identity Manager\Connector Server\jcs\data\jdbm

For backup purposes Create a zip file of these two folders:

etasa

SA Configuration

 

2. Delete the contents of both folders.

3. Restart the connector server service and retest endpoint connectivity.  

4. Test viewing endpoint properties again in Provisioning Manager, in case you receive an error regarding authentication problem open ConnctorXpress, on the right bin expand the provisioning server by typing in the ‘etaadmin’ password. On the ‘CS Configs’ find your connector server, right click ‘Edit CS Config’ and re-enter the Provisioning Server and password (see image)

Additional Information: