When selecing the All Alarms in Spectrum WebClient an HTTP 500 error shows

Document ID : KB000124342
Last Modified Date : 17/01/2019
Show Technical Document Details
Issue:
In the WebClient, clicking on the the All Alarms button produces this error:

HTTP 500 - Internal Server Error occurred, please reload WebClient

Tomcat log shows the following NullPointerException:

java.lang.NullPointerException
 at com.aprisma.spectrum.app.util.attribute.AttributeFilterLogicalNode.toXML(AttributeFilterLogicalNode.java:272)
 at com.ca.spectrum.restful.subscription.WebAlarmSubscriberForDynamicColumns.(WebAlarmSubscriberForDynamicColumns.java:182)
 at com.ca.spectrum.restful.subscription.SubscriptionManager.subscribe(SubscriptionManager.java:442)
 at com.ca.spectrum.restful.servlet.SubscriptionServlet.subscribe(SubscriptionServlet.java:127)
 at com.ca.spectrum.restful.servlet.SubscriptionServlet.POST_subscriptionByXML(SubscriptionServlet.java:75)
 
Cause:
The alarm filter has all Severities in the "Show" option.
Resolution:
This is a limitation of the WebClient.  To resolve this, none of the alarm filters in OneClick can have all of the alarm Severity tab in the "Show" side.  You must move 1 of the Severities to the Hide side.  Most users are not using Suppressed alarms as they are not needed.  The suggested option would be to move the "Suppressed" severity to the Hide side.  This must be done for ALL alarm filters on ALL user models.