MSP Save Failed error due to task Start or Finish Date issues in MSP

Document ID : KB000005264
Last Modified Date : 05/09/2018
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Issue:

When saving back a project from Microsoft Project (MSP) to PPM, receive error: 'Project Save Failed' due to one or more issues with Start and / or Finish Dates for tasks in MSP.

In the app-ca.logs, you will see the following Warning message 'ImportTaskProcessor.doProcess(): Illegal Task Start and/or Finish dates' related to schedulers.postProject.
Tip: To get to the app-ca.logs, see the following KB that will walk both On Premise and SaaS customers on steps to retrieve the log: KB000113183

There are a couple of causes for this issue, but below is one method to reproduce this issue:

Steps to reproduce:

1. Export a project from PPM to MSP

2. In MSP, go to File->Options and set New Tasks created to Manually Scheduled using the below steps:

a. Click on Schedule on the left hand side

b. Set 'New tasks created' to 'Manually Scheduled'

c. Click OK

2. Create a new task in MSP and leave the Start/Finish Dates blank

3. Attempt to Save the project back from MSP to PPM

Expected Results: Project Saves successfully

Actual Results: Receive error message 'Project Save Failed' and project does not save back to PPM

Environment:
This applies to all supported PAS environments for specified releases.
Cause:

This issue happens when there is an invalid date (or invalid date sequence) that is not supported with PPM including: 
1. Tasks missing a Start and/or Finish date, which happens if tasks are created in MSP with Task Mode of Manually Scheduled. If the Start / Finish dates haven't been manually entered, the project will not save back to PPM as PPM requires Start and Finish Dates for all tasks. The value entered must be in a date format, so placeholder values such as TBD or N/A are not allowed as well. 
2. The Start date of any task is greater than the Finish date of the task. The Start date of a task must be less than or equal to the task's Finish date to be able to be saved back to PPM.
 

Resolution:

Solution 1: Check for any tasks missing Start or Finish dates (Date fields are blank or have some other type of value such as TBD or N/A) in the date fields. If any tasks are found with this issue:

  • Enter the missing dates for the task(s) in MSP (or change the Task Mode to of the task to Auto Scheduled which will automatically populate a Start and Finish date for the task)

Note: To prevent this issue going forward, ensure that the following Required setting is made for all projects in MSP:

  1. In MSP, go to File->Options
  2. Click on Schedule on the left hand side
  3. Set 'New tasks created' to 'Auto Scheduled'
  4. Click OK
Solution 2: Check for any tasks that have a Start date later than the task's Finish date. If any are found:
  • Update the task dates so that the task's Start date is earlier than the task's Finish date 
Additional Information:

Reference KB000044475 - Unable to Save Projects back to PPM from MSP if the Project Team has More than One Instance of the Same Role
Reference KB000008031 - In MSP, receive a "Save Failed" error referencing a Unique Constraint Violation in the logs
Reference KB000047612 - What are the recommendations for Auto Scheduled versus Manually Scheduled tasks working in Microsoft Project (MSP) with PPM?
Reference KB000071385 - CA PPM and MSP integration - List of knowledge documents
Reference KB000015956 - CA PPM and MSP integration known defects - Support Technical Document Index
Reference Manage Projects with Microsoft Project (MSP) for more information on integrating with MSP