When running a Fault Tolerance Spectrum environment, it is possible that the Alarm creation time from the Cleared Alarms History tab may be different than the actual alarm creation date.

Document ID : KB000008901
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

When running a Fault Tolerance Spectrum environment, it is possible that the Alarm creation time from the Cleared Alarms History tab may be different than the actual alarm creation date.

Environment:
Spectrum 10.x Fault Tolerant EnviromentOS: Any
Cause:

When an alarm is generated for the first time, an event is generated for the alarm creation.

When the Primary SS fails over, the Secondary SS takes over and generates its own alarm creation event.

Once the alarm is cleared, the "Created On" time user seeing on the "Cleared Alarm History" Tab is the time of alarm event generated by Secondary SpectroSERVER.

 

To reproduce this issue following are the steps:

-------------------------------------------------

1. From a Fault Tolerance Spectrum Environment

2. Model a device in Primary SpectroSERVER.

3. Perform online backup and wait for the backup to complete successfully.

4. Bring the device down and wait for the critical alarm to appear.

5. Now stop the Primary SpectroSERVER

6. Wait for few minutes in order for the alarms to be synchronized.

7. Start the Primary SpectroSERVER and wait for alarms to synchronize.

8. Start the device and wait for the alarm to clear.

9. Once the alarm is cleared, go to Cleared Alarms History Tab and notice the time of the Created on is different from the alarm creation date.

 

 

Resolution:

There is a patch available for Spectrum 10.1.0: 10.01.00.PTF_10.1.0106

 

This is scheduled to be fixed in a future Spectrum release.