When I try to open my PPM project in MSP, nothing happens, it appears the addin is inactive

Document ID : KB000124102
Last Modified Date : 02/04/2019
Show Technical Document Details
Issue:
When I'm in a project and I try to open my scheduler in Microsoft Project (MS Project/MSP), nothing happens and I notice the MSP plugin/ CA Clarity Addin in MSP is showing as inactive. The CA Clarity/PPM Integration tab is not visible in MSP. 
Cause:
This can happen if the addin becomes inactive. One cause where this can keep happening is if the wrong bit level of the MSP Interface is installed and/or duplicates of the Interface are installed on the workstation.
Resolution:

Solution 1: Reactivate the MSP Interface add-in (If this is a one time occurrence)

  1. In MSP go to File->Options->Add-Ins
  2. Click Go next to 'Manage'
  3. Check the check box next to 'The CA PPM AddIn for Microsoft Project'
  4. Click 'OK'
If the issue keeps happening multiple times, proceed to the following solutions:

Solution 2: Delete the below 2.0 folder after creating a backup of the folder.

  1.  Open C:\Users\%USERNAME%\AppData\Local\Apps
(You may need to go into Organize->Folder and Search Options->View->Select radio button 'Show hidden folders, files and drives' and click OK to see the AppData folder)
      2.  Delete the 2.0 folder after creating a backup

      3.   Install the CAClarityAddin: 
  • Navigate to the following folder directory: CA\Clarity\CA Clarity PPM MSPInterface\addin and double click setup.exe to run through the install process for the Addin  
Solution 3: Update the LoadBehavior entry in the registry for the CAClarityAddin after taking a backup of the registry: 

1. From the Start menu, type in 'regedit' to open the registry 
2. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Office\MS Project\Addins\CAClarityAddIn 
3. Right Click on the LoadBehavior, click on Modify 
4. Select Decimal for the Base 
5. For the Value data field, enter a 3, and click OK 


Solution 4: Do a clean uninstall of the Clarity MSP Interface
 

  1. Do a clean uninstall of the Clarity PPM MSP Interface using the steps found at: KB000045862. When reinstalling the interface, make sure the bit level installed of the MSP Interface matches that of MSP. See the following KB for how to check what bit level should be installed KB000124188.
Additional Information:
See KB000005706 - CA PPM Addin Becomes Disabled in Microsoft Project
Reference KB000071385 - CA PPM and MSP integration - List of Knowledge Documents
Reference KB000015956 - CA PPM and MSP integration known defects - Support Technical Document Index