When creating a new ticket using the mail eater the ticket is created but any group defaults are not populated.

Document ID : KB000007454
Last Modified Date : 14/02/2018
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Issue:

When using the mail eater rule that includes a predetermined value for a group and category, the ticket is created by an end user but the group is not assigned.  If it is created by an analyst it is created properly.

The stdlog shows the following error for the end user:

spelsrvr 19212 ERROR text_api.spl 2372 fetch_dob_list last_name (GROUP_NAME) in factory (grp) not found

Cause:

By default the employee role does not has the required permission to set an assignee (group or analyst) and therefore it will fail if it is attempted.

Resolution:

Add additional permissions to the 'Employee' access type.

1. Log in Service Desk as an administrator

2. Go to the administration tab-> Security and role management->Access Type

3. Go to the Roles tab and Edit the 'Employee' access type by set 'Administrator' to the 'Command Line Utility Role'.

4. Save the changes and test again.