When connecting Datamaker to SQL Repository with Integrated Authentication, seeing error 'SQL Native Client 10 is not installed'

Document ID : KB000008109
Last Modified Date : 14/02/2018
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Issue:

Steps to reproduce issue:

(1)        SQL Server 12 is configured with Windows Integrated Authentication

(2)        Install TDM 4.2

(3)        Create a connection profile in TDM to the SQL Repository by creating a System DSN using SQL Server Native Client 11.0 (Pre-requisite for the product installation as per below)

Pre-Requisites.png

(4)        Test the connection to the repository by providing windows authentication which succeeds 

(5)        Start Datamaker and enter the Active Directory credentials after connecting to repository, where it fails with error below

SQL Native Client 10 is not installed 
Please install SQL Native Client 10 and try again. 
The installer can usually be found in "C:\Program Files (x86)\Grid-Tools\GTDatamaker\GTFiles\MS SQL Server Native Client 10.0" 

 

As a workaround, If SQL Server native client 10.0 is installed and used to create the System DSN while creating the connection profile, Datamaker is starting successfully.

Environment:
CA Test Data Manager : 4.2.0.141PB DBMS driver: SNC SQL Native Client(OLE DB) Server DBMS: SQL Server (sql server) Server Version: 12.00.5532
Cause:

This is a known issue in the product and is tracked under internal defect number DE313383.

Resolution:

Please contact CA Support for a patch for this issue and for steps to apply the patch. Please refer to the defect ID DE313383 when you contact CA Support. You can open a support case by going to https://support.ca.com/us.html or https://www.ca.com/us/services-support/ca-support/contact-support.html