When configuring CA Business Intelligence (CABI) with LDAP, following error is received: "The secLdap plugin failed to verify the server administration credentials".

Document ID : KB000033323
Last Modified Date : 14/02/2018
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Issue:

When trying to configure LDAP Integration for CABI using a new LDAP Service Account, receive an error stating:

"The secLdap plugin failed to verify the server administration credentials"

Cause:

The "The secLdap plugin failed to verify the server administration credentials" error means that the credentials cannot be verified by the LDAP server. This can be related to an invalid username and/or password.

Resolution:

Use the correct username and password in the LDAP configuration.  To troubleshoot, determine and verify the correct username and password in the LDAP Server by following the steps below:

1.  Download and install JXplorer on the CABI server. This will allow connection to the LDAP Server to verify if the LDAP configuration values are correct.

2.  When using JXplorer, you need to specify the following:

Host: LDAP HOSTNAME
Port: LDAP port (ex: 389)
BASE DN= <Enter DN used in CABI>
PROTOCOL= <Select LDAP protocol> (ex: LDAPv3)
USER DN= Use the same specified in the CABI LDAP configuration. Remember to use the fully distinguished name when configuring the username. For example,
CN=name,OU=Role-Based,OU=North America,DC=ca,DC=com
Password: <password>

3.  Test the connection to determine if it is successful or not.  This will verify if the values given are correct or not. If not, modify the values until the LDAP connection is successful.

4.  Once the correct LDAP credentials are determines, continue with the CABI-LDAP integration.

Additional Information:

TEC602467 - How to configure CA Business Intelligence (CABI) R3 for LDAP authentication and integrate with CA Service Desk Manager (CA SDM)

CA Business Intelligence - 4.1 SP3 - Integrate with Microsoft Windows Active Directory