When configuring CA Business Intelligence (CABI) with LDAP, following error is received: "The secLdap plugin failed to connect to the specified hosts. (FWB 00028)".

Document ID : KB000033254
Last Modified Date : 14/02/2018
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Issue:

When trying to configure LDAP Integration for CABI using a new LDAP Service Account, receive an error stating:

"The secLdap plugin failed to connect to the specified hosts. (FWB 00028)"

Cause:

The "The secLdap plugin failed to connect to the specified hosts. (FWB 00028)" error means that CABI cannot locate the LDAP server. This can be related to an invalid hostname and/or port and/or LDAP Server down and/or LDAP not accepting connections from the CABI server

Resolution:

Use the correct LDAP server hostname, port, and ensure LDAP Server is up and running and accepting connections.  To troubleshoot, follow the steps below:

 

Verify that the CABI Server can see the LDAP Server:

1) Go to CABI Server

2) Open a command prompt window

3) Perform a ping test to the LDAP server: ping <LDAP Server hostname>

 

Verify the port number and LDAP Server is up and running:

Contact the LDAP Administrator for the LDAP port

 

Verify that LDAP Server is accepting connections to the port number being used:

1) Install telnet tool on the CABI Server

2) Open a command prompt window

3) Perform a telnet from CABI Server to LDAP Server using the port number being used by LDAP: telnet <LDAP Server hostname> <port>

Example: In Microsoft Active Directory the default port number is 389. The telnet command would be: telnet ldap_server_hostname 389

Additional Information:

TEC602467 - How to configure CA Business Intelligence (CABI) R3 for LDAP authentication and integrate with CA Service Desk Manger (CA SDM)

TEC1583402 - When configuring CA Business Intelligence (CABI) with LDAO, following error is received: "The secLdap plugin failed to verify the server administration credentials".