When clicking 'SSH' on the access page nothing happens.

Document ID : KB000045450
Last Modified Date : 14/02/2018
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Issue: 

When clicking SSH to launch CA PAM's built-in SSH applet nothing happens (the applet doesn't launch and no errors pop up). Checking the connection to the device using 'Config > Tools' shows that the connection is fine and port 22 is open. In the Java Console log or Logs.log from the CA PAM Client there are errors like these:

2016-08-02 07:55:53 INFO  - value for 'save-lines' must be an integer (0-8192)     sysout [PAM Access Agent-3]
2016-08-02 07:55:53 INFO  -      sysout [PAM Access Agent-3]
2016-08-02 07:55:53 INFO  - Thank you for using MindTerm...     sysout [PAM Access Agent-3]

Environment:  

CA PAM

Any SSH Device

Cause: 

The 'Buffer Size' Terminal Customization setting is out of range. The accepted range is 0 - 8192.

Resolution:

This Issue could be caused by a setting in one of 3 places. You can determine where the setting was set by figuring out the scope of where this issue occurs. Please note that after changing these settings you MAY need to log out and back in (or even clear Java, Browser and/or CA PAM Client caches) to ensure your previous settings are cleared.

A) This issue occurs for ONE user.

The individual user has set their personal Terminal Customization settings out of range.

  1. Log into CA PAM as this user
  2. At the top, click 'My Info'
  3. Switch to the 'Terminal Customization' tab
  4. Edit the value for 'Buffer Size' to be somewhere in the range of: 0 - 8192
  5. Click Update

B) This issue occurs for ALL (or most) users.

The Global setting for Buffer Size is out of range.

  1. Log into CA PAM as 'super' or using any Global Administrator account
  2. Enter the 'Global Settings'
  3. Find the 'Applet Customization' section
  4. Click 'Configure Terminal Settings' (if these settings aren't already visible)
  5. Edit the value for 'Buffer Size' to be somewhere in the range of: 0 - 8192
  6. Click Save Global Settings

C) This issue occurs for anyone trying to reach a specific device (or multiple devices).

     The Buffer Size setting for these devices is out of range. Remember to follow these steps for each device where this is happening!

  1. Log into CA PAM as any user that has permissions to edit the settings of this device.
  2. Click 'Devices' > 'Manage Devices'
  3. Select the device
  4. Find 'Terminal Customization'
  5. Edit the value for 'Buffer Size' to be somewhere in the range of: 0 - 8192
  6. Click Save