When attempting to delete an old CA Endevor Package, getting a ENBP062E error.

Document ID : KB000008844
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

We are attempting to delete old CA Endevor Packages from a test implementation and getting a ENBP062E error -

ENBP062E  Package ID 'TESTPACKAGE01' is not available for the DELETE action

My TSO ID has been added to the Approver Group.

 

Environment:
z/OS
Cause:

The most likely reason is that you are not one of the Approvers associated with the package.

The Approver IDs in the Approver Group are associated with the package when the package is CAST.

If your ID was added to the Approver Group after the CAST was done, you are not eligible to Delete the package.

Resolution:

Run a Package CONRPT71 and check the Approver Section for the list of IDs that can perform the Delete package action.   

1.  Have one of these Approvers delete the package in Foreground or Batch

or

2.  Use the Package batch facility ENBP1000 in the CSIQJCL library to perform the Delete package action in batch and specify one of the Approvers ids in a USER= parm on the job card. 

 

Additional Information:

For more information on the CONRPT71 Package report, go to the CA Endevor DocOps site ---    

•  Logon using your email address and CA Support Online password

•  In the Select Product drop down box, search for Endevor and select the appropriate version

•  In the Table of Contents on the right, go to :

+ Reporting

+ CA Endevor SCM Reports

>> Package Reports