When a new cohort was created it was not possible to configure it.

Document ID : KB000056660
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem

When a new cohort was created it was not possible to configure it.

Environment

CA Mobile Application Management 14.4

Cause

When the MAM-TENANT table in the db was analysed the newly configured tenant could not be found however there were several rows where the value for TENANT_NAME was null

Solution

Removing these null rows and restarting tomee allowed the missing cohorts to correctly populate.

It is suspected that these null rows were pre-existing prior to the upgrade to 14.4