What versions of APM are compatible with Windows2012 R2?

Document ID : KB000015004
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

APM 9.7 runs currently on Windows Server 2008 R2 environment.
However, the APM Agent environment will be upgraded to Windows 2012 R2 in the near future.

Question:

1. Does Windows 2012 R2 require to be running on EM and Agent together?

2. Other questions of the compatibility for EM and Agent on Windows 2012 R2:
    2-1. What version of Introscope Agent can be supported on Windows Server 2012 R2 and Weblogic 12.1.3?
    2-2. What version of Introscope Enterprise Manager can be supported on Windows Server 2012 R2 + Weblogic 12.1.3?

Answer:

1. Yes, The EM and Agent will work together if both are running Windows 2012 R2 or just the agent.

2.
  2-1.  It depends on the version of Java used:
         Windows Server 2012 R2 + Weblogic 12 C (12.1.3) + JVM 1.7: Supported version: Agent 10.1, 10.2, 10.3, 10.5
         Windows Server 2012 R2 + Weblogic 12 C (12.1.3) + JVM 1.8: Supported version: Agent 9.7, 10.0, 10.1, 10.2, 10.3, 10.5

  2-2. It depends on the version of Java used:
         Windows Server 2012 R2 + JVM 1.7: Supported version: Enterprise Manager 9.6, 9.7, 10.0
         Windows Server 2012 R2 + JVM 1.8: Supported version: Enterprise Manager 10.1, 10.2, 10.3, 10.5