What Version of Java does CA Recommend for CA Asset Portfolio Management 14.1?

Document ID : KB000005003
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:


We have Java (java version "1.7.0_91") installed on our CA Asset Portfolio Management (APM) server.  This version fails our vulnerability scans.
Can you please tell me what version of Java is recommended for APM 14.1 and where I can download it from?

Environment:
CA Asset Portfolio Management 14.1
Resolution:


CA Asset Portfolio Management (APM), during installation, is compatible with Java 32-bit 1.7 (any _xx release level). 

There are two APM components that use Java:  

1. Common Asset viewer (AMS)

2.  CASM service (used for multi-tenanted environments). 

After the APM 14.1 install, upgrade the AMS and CASM components to use a higher version of Java. 

 

See the detailed steps on how to upgrade AMS and CASM to use a higher JAVA version in our APM 14.1 documentation, located here: 

https://docops.ca.com/ca-service-management/14-1/en/implementing/implementing-ca-service-management-14-1/step-4-install-or-upgrade/implementing-ca-it-asset-manager/how-to-install-ca-apm/step-3-upgrade-to-jre-1-8-0_45 

A more graphical representation of the instructions is located in our CA Service Management community forum: 

https://communities.ca.com/docs/DOC-231164257