What version of COBOL can User Exit be compiled?

Document ID : KB000013912
Last Modified Date : 25/04/2018
Show Technical Document Details
Introduction:

The Gen 8.6 Release Notes state:

z/OS COBOL Runtimes Compiled with COBOL 5

With the CA Gen 8.6 release, the z/OS COBOL runtimes are compiled with COBOL V5.1.1 and require runtime support for Enterprise COBOL V5. You may need to apply IBM PTFs to the Language Environment for the runtime support. 

The CA Gen 8.6 z/OS runtimes will run with CA Gen code that was generated and installed with COBOL V5, COBOL V6 or with COBOL V4.  

z/OS applications that are generated with CA Gen 8.6 can use COBOL V4R2 or later.

Question:

What version of COBOL should User Exits use?

Environment:
z/OS Runtime (Host Encyclopedia or z/OS Implementation Toolset)
Answer:

User Exits can be compiled in Gen 8.6 with COBOL V4R2 or V5Rx.