What is the repository version that corresponds to my TDM version?

Document ID : KB000013565
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

As a source of verification that a Datamaker Upgrade has gone smoothly, the version of the database Repositories is checked by software.  As the documentation states, Upgrade the Repository, you will find errors such as the following:

DB version specified in database (3.2E) is invalid.
This version of the software can work with DB version 3.2G only. 
You are connecting with pre-distributed details (rep.xml) - no upgrade is allowed. 
Please contact support.

Or

Test Data Repository version specified in database (3.2H) is invalid. 
This version of the software can work with Test Data Repository versions 3.2I and above only. 
In order to run the upgrade you will need to know the user name and password of a user in the ADMIN group. 
Would you like to attempt an upgrade?

When the database scripts have NOT run that MUST be run after the software installation to keep the database tables in sync with the newly installed software.  Simply following the procedures as set forth in the documentation will result in a complete installation.

Question:

Can you tell the versions of each of the database Repositories since 3.5?

What is the repository version that corresponds to my TDM version?

Answer:

Here is a list:

TDM Version

Repo Version

4.4

 3.2.10 (3.2k)

4.3

3.2.9 (3.2j)

4.2

3.2.8 (3.2i)

4.1

3.2.7 (3.2h)

4.0

3.2.6 (3.2g)

3.8

3.2.5 (3.2f)

3.6

3.2.4 (3.2e)

3.5

3.2.3 (3.2d)