What is highest version of Java that can be used with CA PPM?

Document ID : KB000098409
Last Modified Date : 30/05/2018
Show Technical Document Details
Question:
The IT Security Team has reported vulnerabilities with the Java version installed (1.8.0._101).

This is part of the software delivered by CA PPM.

Please advise what is the latest version of Java which we can safely use, to avoid any issues with CA PPM and Jaspersoft.
Environment:
CA PPM, any version.
Answer:
The CA PPM (and all CA Products) contain Release Notes with all known compatibilities.

To find out the highest certified version of a component, please check the Release Notes.

Check both the currently installed version of CA PPM, and the highest version that is available.

EXAMPLE
For a currently installed CA PPM 15.2 On-Premise site:

Release Notes (On Premise)
https://docops.ca.com/ca-ppm/15-2/en/release-information/release-notes-on-premise#ReleaseNotes(OnPremise)-compatCompatibilities
 
The relevant section of the Release notes is:
Java Runtime 
Oracle Java SE JDK 8 update 101 (64-bit) or higher patch level. (5) 
5. To benefit from new security fixes, CA Technologies recommends running the latest patch level. 

For the highest version that the client can (at the time of writing) move to:

CA PPM 15.4 On-Premise - Release Notes
https://docops.ca.com/ca-ppm/15-4/en/release-information/release-notes-on-premise#ReleaseNotes(OnPremise)-compatCompatibilities 
Java Runtime (2) 
Oracle Java SE JDK 8 update 152 (64-bit) or higher patch level (2)
2. CA Technologies recommends running the latest patch level. 

NOTE: It is always recommended to try out new components and upgrades on a test environment first. NOT live on production.