What are the requirements to set up my IDMS 17.0 DC system to use LE run-time with LE/370 programs?

Document ID : KB000054316
Last Modified Date : 14/02/2018
Show Technical Document Details

Starting in IDMS 17.0, IDMS uses LE/370 for SYSTEM C modules, and therefore the LE/370 runtime (SCEERUN) is required.

There is a mistake in the documentation where it mentions IDMS CV startup would look in LINK
LIST and it will not; it will check CDMSLIB first then the LPA.

Jobs running batch to cv under IDMS 17.0 need SCEERUN since RHDCTD0D is involved and is written in C.
Without SCEERUN; the batch jobs will abend with a User 4093.

Note: If your site currently uses COBOL II and also plan to upgrade to IDMS 17.0; it is strongly recommended that you first upgrade and use the LE/370 runtime while at IDMS release 15.0 and 16.0.

References:

CA IDMS DML Reference - COBOL, Appendix I.1 Considerations for IBM Language Environment