What are the required Red Hat Enterprise Linux 6.0 libraries/packages to install CA Service Desk Manager r12.7?

Document ID : KB000020737
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

This document provides a list of required O/S libraries and RPM Packages that the CA Service Desk Manager (SDM) r12.7 CA SDM installer and post configuration process require. It is recommended to install the 32-bit packages for better compatibility with CA SDM r12.7 CA SDM.

Solution:

To install CA SDM r12.7 CA SDM on Red Hat Enterprise Linux 6.0 successfully, verify that you have the following RPM packages, libraries and their dependencies:

  1. Verify that you have the following Java libraries on Red Hat Linux to launch the CA SDM r12.7 CA SDM installer:

    • java-1.4.2-gcj-compat-1.4.2.0-40jpp.115

  2. java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.115

  • java-1.4.2-gcj-compat-src-1.4.2.0-40jpp.115


To install the above Java packages, you could run a command similar to:

yum install java-1.4.2-gcj-devel.x86_64 java-1.4.2-gcj-javadoc.x86_64 libgcj.i686 libgcj.x86_64 libgcj-devel.i686 libgcj-devel.x86_64 libgcj-src.x86_64

Incase a newer version of java-gcg is already installed, the newer compatible packages could be installed by running a command similar to:

yum install java-1.5.0-gcj-devel.x86_64 java-1.5.0-gcj-javadoc.x86_64 libgcj. i686 libgcj.x86_64 libgcj-devel.i686 libgcj-devel.x86_64 libgcj-src.x86_64

  • To check whether the required packages are installed on your operating system, run the following command:

    rpm -q libXp libXau libxcb libXext libX11 libXtst libXi openssl zlib libselinux keyutils-libs krb5-libs openldap db4 cyrus-sasl-lib pam cracklib audit-libspcre libuuid

  • Compare the output received to the list below to ensure you have at least the minimum release of each package. It is recommended to install the 32-bit packages for better compatibility with CA SDM r12.7 CA SDM Please note that '.i686' in the below list indicates that it is a 32-bit package.

    Required RPM
    libXp-1.0.0-15.1.el6.i686.rpm

    Dependencies

    libXau-1.0.5-1.el6.i686.rpm
    libxcb-1.5.1-1.el6.i686.rpm
    libXext-1.1.3-1.el6.i686.rpm
    libX11-1.3.2-1.el6.i686.rpm

    Required RPM

    libXtst-1.0.99.2-3.el6.i686.rpm

    Dependencies

    libXi-1.3.3-3.el6.i686.rpm

    Required RPM

    openssl-1.0.0-4.el6.i686.rpm

    Dependencies

    zlib-1.2.3-25.el6.i686.rpm
    libselinux-20.94-2.el6.i686.rpm
    keyutils-libs-1.4-1.el6.i686.rpm
    krb5-libs-1.8.2-3.el6.i686.rpm

    Required RPM

    openldap-2.4.19-15.el6.i686.rpm

    Dependencies

    db4-4.7.25-16.el6.i686.rpm

    cyrus-sasl-lib-2.1.23-8.el6.i686.rpm

    Required RPM

    pam-1.1.1-4.el6.i686.rpm

    Dependencies

    cracklib-2.8.16-2.el6.i686.rpm
    audit-libs-2.0.4-1.el6.i686.rpm

    Note: These 32-bit packages (pam-1, cracklib-2, and audit-libs-2) are required on both 32-bit and 64-bit systems.

    Verify that you have the following pcre and libuuid packages:

    pcre-7.8-3.1.el6.i686.rpm
    libuuid-2.17.2-6.el6.i686.rpm

    Note: These 32-bit packages (pcre-7, pam-1, cracklib-2, audit-libs-2 and libuuid-2) are required on both 32-bit and 64-bit systems.

  • If some packages are not installed, install it from the O/S installation media. It is recommended to install the 32-bit packages for better compatibility with CA SDM r12.7 CA SDM. Note: To install a 32-bit package, try the .i686 extension.

    Example:

    To install 64-bit pam package: yum install pam
    To install 32-bit pam package: yum install pam-1.1.1-4.el6.i686

  • To install the 32-bit versions of all the above packages, you could do run a command similar to:

    yum install libXp-1.0.0-15.1.el6.i686 libXau-1.0.5-1.el6.i686 libxcb-1.5.1-1.el6.i686 libXext-1.1.3-1.el6.i686 \
    libX11-1.3.2-1.el6.i686 libXtst-1.0.99.2-3.el6.i686 libXi-1.3.3-3.el6.i686 openssl-1.0.0-4.el6.i686 \
    zlib-1.2.3-25.el6.i686 libselinux-20.94-2.el6.i686 keyutils-libs-1.4-1.el6.i686 krb5-libs-1.8.2-3.el6.i686 \
    openldap-2.4.19-15.el6.i686 db4-4.7.25-16.el6.i686 cyrus-sasl-lib-2.1.23-8.el6.i686 pam-1.1.1-4.el6.i686 \
    cracklib-2.8.16-2.el6.i686 audit-libs-2.0.4-1.el6.i686 pcre-7.8-3.1.el6.i686 libuuid-2.17.2-6.el6.i686

    NOTE: The library releases you have might be slightly newer than those listed above. If so, you need to use that release number instead. For example, openssl-1.0.0-20.el6_2.5.i686 instead of openssl-1.0.0-4.el6.i686.