What ACF2 datasets are required in APF list, LPA, and LINKLIST

Document ID : KB000012929
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

Some z/OS libraries need to be APF authorized to run under z/OS.

Question:

What ACF2 datasets are required in APF list, LPA, and LINKLIST

Environment:
z/OS
Answer:

The ACF2 libraries that ACF2 uses to run need to be APF authorized to work. Any module in the link pack area (pageable LPA, modified LPA, fixed LPA, or dynamic LPA) will be treated by the system as though it came from an APF-authorized library. So you do not need to have the CAX1LPA in the explicit APF list. SYS1.LINKLIB and SYS1.SVCLIB are automatically included as authorized data sets. Other linklist libraries are not automatically APF authorized. If the default for the LNKAUTH system parameter is taken (LNKAUTH=LNKLST), or specified in IEASYSxx or by the operator, libraries in the LNKLST concatenation are also authorized when accessed as part of the LNKLST concatenation. CAX1LINK needs to be APF authorized by one of these methods.  If a library is in the LNKLST concatenation, but is not APF authorized, referencing this library through a JOBLIB or STEPLIB DD statement will cause the library to be considered unauthorized for the duration of the job or step, respectively.