webservices_rest probe is not working

Document ID : KB000108397
Last Modified Date : 30/07/2018
Show Technical Document Details
Issue:
Configured webservices_rest version 8.51 in UIM 8.5 environment and observed that it is giving output for the below url http://umpip:port/rest/version-info

 <?xml version="1.0" encoding="UTF-8" standalone="yes" ?> - <version_info> <value>Nimsoft RESTful web services interface: version: 8.5.1-B, build_number: 150087</value> </version_info> .

but while trying to use http://umpip:port/rest/ or http://umpip:port/rest/alarms its throwing error as HTTP Status 404 - Not Found
 
Environment:
UIM : 8.50
webservices_rest : 8.51
Cause:
The webservices_rest probe is updated to run with the latest CA UIM database schema. When updating UIM, be sure to download the webservices_rest probe with the corresponding version number. Do not download webservices_rest with a later version than your CA UIM, doing so may break endpoints.
Resolution:
Please download the webservices_rest-8.4.7.zip probe version
This probe version can be downloaded from "http://support.nimsoft.com/Default.aspx?center=felles/archive&state=hidden" path

Follow the below article before you deploy this probe. Make sure to delete the existing version of probe and deploy this version.
https://comm.support.ca.com/kb/How-to-remove-webservicesrest-package/KB000010370
Additional Information:
Reference:
https://docops.ca.com/ca-unified-infrastructure-management-probes/ga/en/probe-development-tools/restful-web-services/webservices_rest-apis