Webagent intialization issue

Document ID : KB000099432
Last Modified Date : 01/06/2018
Show Technical Document Details
Issue:
We have installed a Web Agent on Linux.Despite the Web Agent is starting, it is unable to service
the requests.

Troubleshooting steps: 

1. After noticing the semaphore related info messages we suggested the
   customer to clean up the semaphore (Ref :
   https://communities.ca.com/message/241987912-re-unable-to-start-webagent?commentID=241987912&et=watches.email.thread#comment-241987912).
2. The handshake error was noted in the policy server logs. In
   response to this, we asked the customer to re-register the trusted
   host which was successful.

Currently, we see the following error in the webagent log:

1. [9091/4034889472][Mon Apr 30 2018
   16:40:16][CSmPluginManager.cpp:75][ERROR][sm-AgentFramework-00090]
   ADMIN: Missing or invalid plugin configuration setting
   'loadplugin'.

2. [9091/4034889472][Mon Apr 30 2018
   16:40:16][CSmAdminManager.cpp:191][ERROR][sm-AgentFramework-00270]
   ADMIN: Unable to get plugin context from the Plugin Manager.

3. [9091/4034889472][Mon Apr 30 2018
   16:40:16][CSmHighLevelAgent.cpp:122][ERROR][sm-AgentFramework-00400]
   HLA: Failed to initialize 'Administration Manager'.

4. [9090/3950962432][Mon Apr 30 2018
   16:41:14][CSmLowLevelAgent.cpp:5233][INFO][sm-AgentFramework-00510]
   LLA: Logging initialized.

I suspect some plugins or libraries are missing. How can we fix this ?
Resolution:
In WebAgent.conf, include the serverpath and the loadplugin lines to
solve the issue.

Please see also below differences from the sample out of the box
configuration and the configuration from your environment:

your webagent.conf 

AgentConfigObject="mywebagent" 
HostConfigFile="/opt/CA/webagent/SmHost.conf" 
EnableWebAgent="YES" 
LogFileName="/var/log/apache/webagent.log" 
TraceFile="YES" 
TraceFileName="/var/log/apache/webagenttrace.log" 
TraceConfigFile="/opt/CA/webagent/config/WebAgentTrace.conf" 
TraceAppend:"YES" 
TraceFormat:"default" 
TraceDelimiter:"|" 
TraceFileSize:"100" 

out of the box webagent.conf file : 

LOCALE=en-US 

#agentname="<AgentName>, <IPAddress>" 
HostConfigFile="/opt/CA/webagent/config/SmHost.conf" 
AgentConfigObject="mywebagent" 
EnableWebAgent="YES" 
ServerPath="/opt/apache/conf" 
#localconfigfile="/opt/apache/conf/LocalConfig.conf" 
LoadPlugin="/opt/CA/webagent/bin/libHttpPlugin.so" 
#LoadPlugin="/opt/CA/webagent/bin/libAffiliate10Plugin.so" 
#LoadPlugin="/opt/CA/webagent/bin/libSAMLAffiliatePlugin.so" 
#LoadPlugin="/opt/CA/webagent/bin/libeTSSOPlugin.so" 
#LoadPlugin="/opt/CA/webagent/bin/libIntroscopePlugin.so" 
#LoadPlugin="/opt/CA/webagent/bin/libSAMLDataPlugin.so" 
#LoadPlugin="/opt/CA/webagent/bin/libOpenIDPlugin.so" 
#LoadPlugin="/opt/CA/webagent/bin/libDisambiguatePlugin.so" 
#LoadPlugin="/opt/CA/webagent/bin/libOAuthPlugin.so" 
#LoadPlugin="/opt/CA/webagent/bin/libCertSessionLinkerPlugin.so" 
AgentIdFile="/opt/apache2429/conf/AgentId.dat"