Web Intelligence report hang

Document ID : KB000044592
Last Modified Date : 14/02/2018
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Introduction:

Issue:
boxi webI report not finished after several hours.
We see in the stdlog some fetch, but knowing the query we see the fetch did not return all the rows and the report hang.

Steps to Reproduce:
1.    create lot of incident in the mdb
2.    create a webI report with lot of filters, but report is still returning lot of rows.
3.    if the report elapse time is 3 mn, schedule it every 4 mn.
4.    we should see in the report history some report started after the hang one finished.
5.  Due to lot of report on hang, memory of tomcat is increasing


Environment:
Service Desk 12.9
Boxi 3.1


Cause:
Some WebI queries causing Service Desk hang on fetching data.


Resolution:
On Service Desk Server, increase the odbc block size
1. Execute at the command lmind on Service Desk Server
pdm_options_mgr -c -s ODBC_BLOCKSIZE -v 10000 -a pdm_option.inst
pdm_options_mgr -c -s ODBC_BLOCKSIZE -v 10000 -a pdm_option.inst -t

2. Restart Service Desk Service

Instructions:
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