Web Agent not Starting

Document ID : KB000091953
Last Modified Date : 19/04/2018
Show Technical Document Details
Issue:
Customer re-registered Web Agent after IP address and DNS name change, and now the agent will not start or produce logs.
Cause:
Webagent.conf file was referencing an invalid Agent Configuration Object (ACO) name.  When a Web Agent initializes, it first reads Webagent.conf to determine if the agent is enabled, and if so, where to find the Host Configuration file (SmHost.conf) as well as the ACO name.  The agent next loads the SmHost.conf file which contains the bootstrap Policy Server addresses/ports, the Host Configuration Object (HCO) name, and the shared secret required to make connections to the Policy Servers.   
Resolution:
Update webagent.conf to use a valid ACO name.