We have successfully re-installed Agent in WA on production server but when we are triggering any job it is going in ready state

Document ID : KB000044581
Last Modified Date : 14/02/2018
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Issue: 

We have successfully re-installed Agent in WA on production server but when we are triggering any job it is going in ready state.

Environment:  

Applies to all DE and Agent environments for the supported releases.

Cause: 

Job in Ready state indicates Agent and Manager communication issue. The Agent's receiver and transmitter logs should be reviewed to determine the root cause. For example;

This is an exception in the Agent's receiver log;

07/04/2016 05:46:37.550 EDT-0400 1 TCP/IP Controller Plugin.Receiver pool thread <Regular:2>.CybReceiverChannel.receive[:213] - Can't parse the message: cybermation.library.communications.CybConversationWrongMessageException: Unknown manager .NAK sent

The 'Unknown manager' message exception implies that the manager ID is unknown to the Agent.

Resolution:

Verify that the manager ID is valid in agentparm.txt file;

communication.managerid_1=<manager ID> 

Steps:

1. On the Desktop Client CLI perspective, issue the ABOUT command to verify the DE manager ID;

CA Workload Automation Server Id: <manager ID>

2. Copy the manager ID to replace the wrong manager ID in agentparm.txt file;

communication.managerid_1=<manager ID>

3. Restarted the agent